View Full Version : Possible RadeonPCI disables video capture?

06-03-2001, 02:18 PM
I don't know if the Radeon is the culprit but I've noticed that I can no longer capture video on my Beige G3 300 MT with the onboard AV personality card. The Radeon os the most recent addition to my system. This happens in ANY video capture utility. Anything to do with video settings is grayed out. I tried a 9.1 Base extension set (without any ATi Radeon extensions) and still the same problem.

I've done everything short of physically pulling the RadeonPCI out of the machine, mostly because I'm not going thru all that everytime I want to capture video.

As a side note, I tried a USB InterView on it as well with similar results.

Could the physical hardware presence of the RadeonPCI have anything to do with it?

Thanks in advance for any thoughts or ideas.

PS - Also running an X partition with it's own virgin Classic... although I don't know why that would make a difference when started up from OS 9.1.

[This message has been edited by StrawHand (edited 03 June 2001).]

06-03-2001, 11:54 PM

You might want to check out a thread that I started on a similar problem with the VR128 card from ATI. Had to do with upgrading and then losing the ability to capture. The difference was that I could still capture using a USB Interview device... there was some suggestion of removing AppleGuide stuff etc..


06-08-2001, 07:13 PM
make sure that you have the VideoPlayer application and extension installed and loading in your extensions folder....that's what MacOS uses for video capture. The definitive way to figure this out will be to do a clean install, ensure you have regained capture ability, mark and lock your base set so it cannot be modified, then install the Radeon 1.1.1 resources.

about the only thing you could have possibly done from the standpoint of hardware is popped up your PERCH card up out of its slot by bumping into it or something.

look at it carefully. You will see that it can pop up out of the slot in front, near the leading edge, esp if you have the retaining screw on the PCI card carrier cranked down hard. Just reseat the card, firmly and completely, and that should take care of that.


06-11-2001, 06:47 PM
Hey SH: I just saw this. I have a gut feel that the installation of OS X had a hand in this problem. It does some wierd things on a beige G3. Apple stretched it for the Beige.

All I did was boot the OS X CD on my wife's beige; didn't install it. As a result ATA channel 1 disappeared, like it never existed. I bought a new Apple CD player (at an exorbitant price) and it wouldn't work. I was about to send the logic board off for repair, when I booted while depressing the OPTION key. The ATA channel returned. I was able to make the fix permanent by flushing the NVRAM (cold start).

Wonder if anyone else lost the use of PERCH after installing OS X? Does it show in ASP?

06-12-2001, 03:28 AM
welll....to add to the weird bG3 tales of OSX woe....spud was directed to install a 500Mhz G4 into banshee, during one of our typical shuffling of processors. Keep in mind that this bG3 has been running w a dual-G4 500Mhz Velocity.

well. She HAS been running both 500MHz G3's and 450MHz G3's (doing some testing), and now, she refuses to boot with a G4 ZIF installed again. I kid you not.

we're swapping known-good ZIF out for the second time now, and spud completely rebuilt her today. He suspects one piece of memory is funky, but other than that, she should be solid.

this machine was the rock of friggin' Gibralter before OSX. Now.......when she runs, she runs great. But getting her to boot smoothly between the two OS's...phew.

and OSX definitely does something to these machines. It modifies ROM, something.

they are never the same afterwards.

06-12-2001, 11:27 AM
Just checking back in after reading a few posts... and I couldn't agree more with magician. My Beige G3 used to be as rock-solid as.... as... well... a REALLY solid rock, running 9.1.

Silly me to think that if I parition correctly and keep OSs from contaminating each other that I will be able to run 9.1 as smoothly as I had before.

Last night I booted up as usual into OS 9.1 and experienced the "missing ATA 1 bus" problem. I zapped the PRAM, checked connections.... nothing, no CD... no internal ZIP. Finally on a lark I booted the machine with a CD in the drive and lo and behold.... HOORAY!!!! it's back and working fine.... don't ask me!

Speaking of rewriting ROMs... this may also be part of my problem... come to think of it I may not have tried to capture video since before Feb 23rd. Perhaps it's OS X. Anyone know of a freeware/shareware Cocoa analog video capture app I could use to see if OS X sees the video card IN?

I'm not particularly Unix savvy but I can get around in the terminal. Perhaps there are some command-line monkey-shines I can perform in order to see if the hardware is there?

[This message has been edited by StrawHand (edited 12 June 2001).]

06-13-2001, 03:55 PM
Why don't you try this: while booted from 9.1, be sure the startup control panel is set to your 9.1 volume, shut down, restart holding dowm the CMD-OPT-P-R for three BOINGS and then let it start. That flushes the NVRAM. Now try the AV PERCH card.

No warranties given.

06-13-2001, 05:22 PM
Thanks Louie, just tried it.... that's a big negatory good buddy.

Still the same, but thank you.

06-13-2001, 07:28 PM
Pulling the battery is probably the best way to flush P/NVRAM IMHO. It probably only needs to be out about 2 minutes (or less?) but I like to leave it out for about 5 minutes or more. You NEVER know and large capacitors can take a while to drain http://www.macgurus.com/ubb/eek.gif

I wonder if there is some 'bootRAM' file that is altered and is causing issues?

For X I like to have a DEDICATED partition for 9/Classic and CLASSIC ONLY. I then have another partition for 9/X+all the updates & dev tools. I have only installed on a YOSE & Sawtooth/PC133. The V3 on the YOSE killed X. We have a few BeigeG3 boxes at work... glade we are not going to X yet. http://macgurus.com/infopop/emoticons/icon_smile.gif

06-14-2001, 07:47 PM
yeah....I'm thinking X will be excellent in a few more months, probably by Christmas, even.....about the same time Office for X is released, and X ships preinstalled on all new Macs. It ain't for the meek on bG3's, IMO.

this is the killer: spud got banshee up and running yesterday, shut her down to swap out SCSI boards, and wham: she refuses to boot all over again. She runs under a G3, just fine. She seems to hate the G4. Again.

it's really pissing me off. I loved playing on her. She's really a wicked-fast little unit.